
FLASH DRAWING BASICS

AND TOOLBAR DEFINITIONS

. [image: image1.wmf]
The most important thing to understand is the distinction between outlines and fills.

When you draw a line there is no fill - only the outline.

When you draw a rectangle (or a circle) you actually draw two things: The outline (border) and the fill. Unlike most other programs, Flash doesn't automatically combine these two into one object.

PENCIL TOOL
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The Pencil tool is used in much the same way that you would use a real pencil to draw. Simply select the tool and drag on the Stage to draw with the Pencil tool. 

SHIFT key : Constrain directions:
You can press the Shift key while dragging to constrain lines to vertical or horizontal directions. 

Colors:
You can specify the color with the Stroke Color Tool.

Color Tools:
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Smoothing and Straightening:
You can apply smoothing or straightening to the lines by setting a Pencil mode.

Pencil Modes: [image: image4.wmf]
Stroke panel:
Finally, you can specify line style (solid, dotted etc.), line width in pixels and color using the Stroke panel.
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BRUSH TOOL
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The Brush tool draws brushlike strokes, as if you were painting. It lets you create special effects, including calligraphic effects.

Unlike the Pencil tool, the Brush tool draws both a fill and an outline. 

Brush Modes:
You can specify the Brush Mode to define the way the tool works:

-Paint Normal - paints over lines and fills on the same layer.

-Paint Behind - paints in blank areas of the Stage on the same layer, leaving lines and fills unaffected.

-Paint Selection - applies a new fill to the selection when you select a fill in the Fill modifier or the Fill panel. (This option is the same as simply selecting a filled area and applying a new fill.)

-Paint Fills - paints fills and empty areas, leaving lines unaffected.

-Paint Inside - paints the fill in which you start a brush stroke and never paints lines. This works much like a smart coloring book that never allows you to paint outside the lines. If you start painting in an empty area, the fill doesn't affect any existing filled areas.

Brush Modes:
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NONE | NORMAL | BEHIND | SELECTION | FILLS | INSIDE

Brush Size:

Also, in the Brush options, there is a drop down that lets you select the size of the brush. Simply click the size you want.

Brush Shape:

Finally, the Brush options lets you select the shape of the brush. Try experimenting with the different shapes and see what effect each offers.

Lock Fill:

The last option listed under Brush options, is the Lock Fill option. The explanation for this is a bit tricky.

When you use the brush tool in it's default state this option is not turned on. Let's assume that you selected a gradient fill and painted something using the brush tool. In this case the brush tool would use the center of your painting as the center for the gradient fill.

Now, if you paint yet another drawing next to the first one, Flash will use the new drawing's center as center for the gradient fill.

However, had you pressed the "Lock Fill" option before drawing the second painting, Flash will maintain the gradient center from the first painting.

The best way to understand this option is trial and error, so if you don't get the above explanation, then try painting with and without the "Lock Fill" option set. While doing so, make sure that you use a gradient fill for the drawing or you won't see any effect at all (because plain colored fills have no center).

LINE TOOL
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The Line tool is used in much the same way that you would use a real pencil to draw with a ruler. Simply select the tool and drag on the Stage to draw a straight line between the start and end points.

SHIFT key : Constrain angles

You can press the Shift key while dragging to constrain possible angles for the line. By default this will only allow for lines that are either horizontal, vertical or 45 degrees between.

Curving

You can turn a straight line into a curve with the Arrow tool[image: image9.wmf]
1: Make sure the line is not selected (you can do this by clicking somewhere on an empty spot on the stage).

2: Select the Arrow tool.

3: Click on the line, and while holding down the mouse button, drag the curve.

4: Release the mouse button and your curve is finished.

Curving Lines and Edges:
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Moving

You can move a line with the mouse, quite similar to how you'd turn it into a curve or you can move it with the arrow keys.

1: Select the Arrow tool.

2: Make sure the line is selected (you can do this by clicking once on the line then release the mouse button).

3a: Click on the line, and while holding down the mouse button, move it to the new position.

3b: Press the arrow keys on your keyboard to move the line.

Precise size and positioning:

You can position the line perfectly by using the info panel.

Info Panel : Window > Panels > Info
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The "square" connected to the line where it says "Click this square" is used to set the origin for coordinates - either at top left or center of the stage.

Fields for X and Y are used to enter the position of the selected object.

Fields for W and H are used to enter the width and height of the selected object.

When working with lines, one might think that height would be 1 for a thin line. However, width and height refers to the square between the start and end points of the selected object.

A horizontal line that is 100 pixels wide and 1 pixel high spans a square of 100 x 1 pixels.

OVAL TOOL
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The Oval tool is used to make circular objects. Simply select the tool and drag on the Stage to draw a circle that spans between the start and end points.

SHIFT key : Round Circles

You can press the Shift key while dragging to ensure your circle is perfectly round.

Apple key +G : Grouping Outline with Fill

When you draw a circle, Flash actually creates two objects: the fill and the outline. This may cause problems if you try to move your circle to a new position, because if you fail to select both objects, only the one selected will be moved. To avoid this it's often a good idea to "group" the outline with the fill, thus locking them together as if it was a single object.

1: Make sure both the fill and the outline is selected.

(You can do this in two ways: 1) Select the Arrow tool in the toolbox, and while holding down the SHIFT key click on both the fill and the outline. 2) Select the Arrow tool in the toolbox, and drag a rectangle outside your circle)

2: Press Apple key+G to group the selected objects.

(If at a later point you want to "break" apart the grouped objects, you can do it by selecting the grouped object then pressing Apple key+B).

Precise size and positioning:

You can position the oval perfectly using the info panel.

Info Panel : Window > Panels > Info
[image: image13.wmf]
The "square" connected to the line where it says "Click this square" is used to set the origin for coordinates - either at top left or center of the stage.

Fields for X and Y are used to enter the position of the selected object.

Fields for W and H are used to enter the width and height of the selected object.

RECTANGLE TOOL
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The Rectangle tool is used to make rectangular objects. Simply select the tool and drag on the Stage to draw a rectangle that spans between the start and end points.

SHIFT key : Proportioned Squares

You can press the Shift key while dragging to constrain proportions for the rectangle, to ensure your rectangle is a perfect square.

Rounded Corners

You can specify the rounding of the corners with the "Round Rectangle Options" at the bottom of the toolbox.

Apple key+G : Grouping Outline with Fill

When you draw a rectangle, Flash actually creates two objects: the fill and the outline. This may cause problems if you want to move your rectangle to a new position, because if you fail to select both objects, only the one selected will be moved. To avoid this it's often a good idea to "group" the outline with the fill, thus locking them together as if they were a single object.

1: Make sure both the fill and the outline are selected.

(You can do this in two ways: 1) Select the Arrow tool in the toolbox, and while holding down the SHIFT key click on both the fill and the outline. 2) Select the Arrow tool in the toolbox, and drag a rectangle outside your rectangle)

2: Press Apple key +G to group the selected objects.

(If at a later point you want to "break" apart the grouped objects, you can do it by selecting the grouped object then pressing Apple key +B).

Skewing

Before skewing a rectangle make sure it has been grouped. You can skew the rectangle in two ways.

To skew an object by dragging:

1. Select the object with the Arrow tool.

2. Click the Rotate button in the toolbox options.

3. Drag one of the centered handles.
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To skew an object using the Transform panel:

1. Select the object.

2. Choose Window > Panels> Transform.

3. Click Skew.

4. Enter angles for the horizontal and vertical values.
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Precise size and positioning

You can position the Rectangle perfectly using the info panel.

Info Panel : Window > Panels > Info
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The "square" connected to the line where it says "Click this square" is used to set the origin for coordinates - either at top left or center of the stage.

Fields for X and Y are used to enter the position of the selected object.

Fields for W and H are used to enter the width and height of the selected object.

ERASER TOOL
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The Erase tool works similar to a classic eraser. Simply select the tool and drag on the Stage to erase things.

Double-click Eraser Tool: Erase All

You can double click the Eraser tool to delete everything on the stage. (If you happen to do this by mistake you can always click Apple key+Z to undo).

[image: image19.wmf]Using the Eraser Mode Option
In the options listed at the bottom of the toolbox you can specify the Eraser Mode:

    * Erase Normal - erases strokes and fills on the same layer.

    * Erase Fills - erases only fills; strokes are not affected.

    * Erase Lines - erases only strokes; fills are not affected.

    * Erase Selected Fills - erases only the currently selected fills and does not affect strokes, selected or not. (Select the fills you want to erase before using the Eraser tool in this mode.)

    * Erase Inside - erases only the fill on which you begin the eraser stroke. If you begin erasing from an empty point, nothing will be erased. Strokes are unaffected by the eraser in this mode.

[image: image20.wmf] Using the Faucet Option
To remove stroke segments or filled areas:

1. Select the Eraser tool and then click the Faucet modifier.

2. Click the stroke segment or filled area that you want to delete.

[image: image21.wmf]Using the Eraser Shape Option
In the options listed at the bottom of the toolbox there is a drop down that lets you specify the Eraser shape and size.

Use this option to customize the size and look of the eraser.

Alternative ways to delete things

There are other ways to delete things besides using the Eraser tool.

The most common way is to select one or more objects and then press the DEL key on the keyboard.

You can delete an entire layer by clicking the layer at the top of your screen and dragging it to the Trash bin.

You can delete several frames at once by selecting the frames (and layers) in the timeline, then right click and choose "cut frames".

INK BOTTLE TOOL
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The Ink Bottle tool lets you change the stroke color, line width, and style of lines or shape outlines.

Using the Ink Bottle tool, rather than selecting individual lines and objects, makes it easier to change the stroke attributes of multiple objects at one time.

To use the Ink Bottle tool:

1. Select the Ink Bottle tool.

2. Choose a stroke color as described in Using the Stroke and Fill controls in the toolbox.

3. Choose line style and line width from the Stroke panel.

Stroke Panel : Window > Panels > Stroke
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4. Click an object on the Stage to apply the stroke modifications.

Applying outlines to existing objects:

You can use the stroke tool to apply outlines even for things that were initially made without outlines.

For example, if you initially created a rectangle with no outline, then later decided you wanted an outline, simply use the Ink Bottle tool as described above and a new outline will be applied.

PAINT BUCKET TOOL
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The Paint Bucket tool fills enclosed areas with color.

It can both fill empty areas and change the color of already painted areas.

You can paint with solid colors, gradient fills, and bitmap fills.

You can also use the Paint Bucket tool to adjust the size, direction, and center of gradient and bitmap fills.

To use the Paint Bucket tool to fill an area:

1. Select the Paint Bucket tool.

2. Choose a fill color from the color tool box.

3. Click the Gap Size modifier[image: image25.wmf]and choose a gap size option:

    * Don't Close Gaps : if you want to close gaps manually before filling the shape. Closing gaps manually can be faster for complex drawings.

    * Choose one of the Close options to have Flash fill a shape that has gaps.

4. Click the shape or enclosed area that you want to fill.

To adjust a gradient or bitmap fill with the Paint Bucket tool:

1. Select the Paint Bucket tool.

2. Click the Transform Fill[image: image26.wmf]
3. Click an area filled with a gradient or bitmap fill.

Depending on the type of object you're painting you will see different handles:

a. Transform Linear Gradient Fills
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b. Transform Radial Gradient Fills
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c. Transform Bitmap Fills
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4. Reshape the fill in any of the following ways:

a. To reposition the center point, drag the center point.
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b. To change the width of the fill, drag the square handle on the side of the bounding box. (This option resizes only the fill, not the object containing the fill.)
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c. To change the height of the fill, drag the square handle at the bottom of the bounding box.
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d. To rotate the fill, drag the circular rotation handle at the corner. You can also drag the lowest handle on the bounding circle of a circular gradient or fill.
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e. To scale a linear gradient, drag the square handle at the center of the bounding box.
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f. To change the radius of a circular gradient, drag the middle circular handle on the bounding circle.
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g. To skew or slant a fill within a shape, drag one of the circular handles on the top or right side of the bounding box.
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h. To tile (repeat) a bitmap inside a shape, scale the fill.
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Note: To see all of the handles when working with large fills or fills close to the edge of the Stage, choose View > Work Area.

EYE DROPPER TOOL
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You can use the Eye Dropper tool to copy fill and stroke attributes from objects.

To use the Eyedropper tool:

1. Select the Eye Dropper tool and click the object whose attributes you want to copy. (When you click a stroke, the tool automatically changes to the Ink Bottle tool. When you click a filled area, the tool automatically changes to the Paint Bucket tool)

2. Click the object that you want to apply the new attributes to.

Using the Eyedropper tool to select a bitmap fill:

Rather than painting with a fixed color or gradient you can paint using a bitmap image. A very important special use of the eyedropper tool is to select bitmap fills.

1. Place a bitmap image on the stage. Either drag it from your symbol library (Apple key +L or Window > Library) or import a bitmap image from a file (Apple key +R or File > Import).

2. Make sure the imported bitmap is selected. (If not: click on it with the Arrow tool).

3. Press Apple key +B to break apart the image.

4. Select the Eye Dropper tool and click on the image.

You will now see a miniature of your image in the Color Fill tool box. Use the Paint Bucket tool to apply the bitmap fill to an object. (Note: you can apply the fill to any filled object as well as any closed outlined area.)

PEN TOOL
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The Pen tool is the only tool in the Flash toolbox that doesn't resemble a tool from everyday life. Although the tool symbol looks a lot like an ordinary pen it works quite a bit different.

The purpose of the Pen tool is to allow you to draw precise paths as straight lines or smooth, flowing curves.

You can create straight or curved line segments and adjust the angle and length of straight segments and the slope of curved segments afterwards.

There are two methods for drawing with the Pen tool:

1. Click to create points on straight line segments

2. Click and drag to create points on curved line segments.

Each method is described below.

To draw straight lines with the Pen tool:

1. Select the Pen tool.

2. Click on the stage to set points, and watch how Flash automatically connects points as you set them.
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3. To complete the path leaving it as either an open or closed shape. Do one of the following:

3a. To complete an open path, double click the last point or click the Pen tool in the toolbox, or Control-click (Windows) or Command-click (Macintosh) anywhere away from the path.

3b. To close a path, position the Pen tool over the first anchor point. A small circle appears next to the pen tip when it is positioned correctly. Click to close the path, and watch how Flash automatic adds a fill once the path becomes a closed outline.
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To draw curves with the Pen tool:

First look at this 4 step example:

An example of curve drawing with the pen tool

>next page
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1. Select the pen tool and click twice to create a straight line - on the second click keep the mouse button down.

2. Drag the mouse towards yourself - which will cause the control line to appear. The control line is pulled in the one end and has a drag point in the other end.

3. Move the mouse from side to side (B) and forward and down (A)- still holding down the button, and see how the drag point moves accordingly.

The drag point defines both how much and in which direction the initial straight line is dragged.

4. When the curve on the initial straight line is shaped the way you want it release the mouse button, and the end result appears while the control line disappears.

